201807GLPI9.3最新版安装笔记记录
in GLPI with 2 comments

201807GLPI9.3最新版安装笔记记录

in GLPI with 2 comments

9.3版本的glpi需要composer来管理php依赖(好像是这么说法,说得不对请轻喷),所以服务器需要预先把composer安装好,以下为过程记录,给自己留个笔记:

1、最终效果:
最终效果

2、首先获取glpi的最新源码:有多种途径,我选择从github拉取:

git clone https://github.com/glpi-project/glpi.git

这里给个小贴士:后边想更新glpi源码到最新版本,只需要git pull即可,很方便。

3.1、获取composer:

php -r "copy('https://install.phpcomposer.com/installer', 'composer-setup.php');"

3.2、安装composer:

php composer-setup.php

4、用cd 进glpi目录,用composer补全依赖:

composer install --no-dev

5、GLPI9.3最新简体中文汉化包下载

下载地址:

点击下载

Responses
  1. 小白

    大佬,能不嫩能够出个最新教程,小白一枚,网上资源旧又乱,搞了好几次都是php环境没装对。能否指导一波。。。

    Reply
  2. 小白

    你好,请问能不能说的详细一点步骤。composer不会用

    Reply